In the past days I experienced errors in my anti-spam plugin by Jay Allen on my old MT installation. Turns out that the blacklist of spammers to filter on became too long. The original blacklist plugin stores all blacklisted entries in one database record, which over time becomes too long. Newer blacklist versions have that solved but require a newer version of Moveable Type.
Bottom line: Adding three new domains to my blacklist turned into buying and installing Moveable Type 3.2.
Upgrading went without a glitch.